Organization unavailable after login

in recent months we deployed Self-Hosted Bitwarden to our company with ~50 users. All users are members of a single Organization, where multiple collections are created. Each of the collections contains hundreds of items.

After the New Year, we performed an upgrade to the latest version (update, updateself) as described in the documentation. This upgrade was completed succesfully and users reported no issues in the following days.

Since then, I’ve had one not very descriptive report of an error loading data, but I will ignore it for now, as there are not much conclusive details from the user.

Today I logged in via web ui succesfully (authenticated via my password and second factor), however it seemed I see no data:

  1. I didn’t see any items in my vault
  2. I didn’t see the organization at all
    I tried to hard refresh the page, but that didn’t help. This broadly matched the user’s description before.

After about a minute, I closed the browser window and tried to login again, this time with no success, only brief error notification was shown “Error fetching data”.
In the meantime, I connected to the host to see what is going on the system, but at first glance nothing seemed off.
In the next three minutes after few tries, I was able to login again, this time with all the data available.

The status of the system as investigated after the succesfull login:

  1. no errors in dmesg (so no OOM hard kill)
  2. docker logs ok
  3. container logs clean
  4. “docker ps” shows all containers healthy with 13 days uptime (that matches the upgrade time)
  5. bwdata/logs no error

So my questions are rather simple:

  1. How would you diagnose this type of problem? Bitwarden logs are almost non-existent, if I am not missing something.
  2. Did any of you experienced similiar problem lately?

Thank you