On-prem installation - nginx container issue

Dear community,

I have a problem with a on premise installation. I installed bitwarden regulary but bitwarden-nginx container is restarting constantly. Following error occurrs:

“2021/02/04 16:16:14 [emerg] 1#1: socket() [::]:8080 failed (97: Address family not supported by protocol)”.

We don’t have IPV6 support in our organization network. Can you please let me know how to disable IPV6 in nginx container or some other solution to stop receiving this, and get container “Up”?

Regards,
Milica

1 Like

Hi Milica,
I had this issue too, I resloved it - until the next update - with commenting out the lines
in bwdata/nginx/default.conf:

#listen [::]:8080 default_server;
and
#listen [::]:8443 ssl http2;

for me it looks like there is no other way to solve it at the moment.
Anyone else has a better idea to solve this?

regards,
Ulf

Hi Ulf,

Thanks, this solved the problem.

Hope during the next updates there will be better solution for this.

Regards,
Milica

Hi Ulf,

Any ideas how do you handle automatic updates (using cron job)? Do you have to make changes every time after an update?

Regards,
Milica

Hi Milica,

updates: yes via cron ./bitwarden.sh updateself && ./bitwarden.sh update should do it.
Regarding the changes you did, there are some ways to workaround but yes you are right
you have to make the changes every time after an update.

One workaround is

  • fork the docker container where you need to do the changes.
  • do the changes in the fork.
  • do the update
  • git merge your changes back to the updated container.
    You may have a look here: Justin James

Another workaround would be to build you own docker image and use the bitwarden image as parent …

But I think it’ would be good to open a bug/feature request with bitwarden and ask them to build a switch into the global.override.env where you could simply turn off and on ipv6.
What do you think?

regards,
Ulf

Hi Ulf,

Many thanks for your proper explanation.

Yes, I will firstly wait for the new release if it is fixed.

Regards,
Milica

Another option to try would be to disable nginx config file generation with generate_nginx_config: false in ./bwdata/config.yml as discussed in similar GitHub issue:


I wouldn’t expect this to be changed without opening a request to support it.

Current code state is still the same. It will require adding template support around the IPv6 blocks:

Hi,

Thanks for the info. Do you know how can I open request for them? Is it here on Bitwarden community page? Is there some flag to to mark it as a request?

Thanks,
Milica