New Browser Extension not working with Biometric login

@tgreer 1Password does it also, when touch id can not be used it e.g. the lid is closed, the master password must be used. The have to comply to the same Apple dev rules.

1 Like

Of course :slight_smile:

That was more or less my point, once we kick-off the Touch ID flow it’s going to use the fingerprint or computer password. To prevent that, I believe we’d need to prompt for Master Password instead of invoking Touch ID.

1 Like

Seems from this thread that many have had this issue resolved for them. I’ve only started using Bitwarden within the last few weeks (love it), but I’m experiencing this issue right now. Trying to get the chrome integration to use Windows Hello. @tgreer can you let me know if you see this as fixed?

I’ve tried disabling the “Require verification for browser integration” option to see if that caused the issue but no change.

Versions
Chrome: Version 89.0.4389.82 (Official Build) (64-bit)
Chrome/bw integration: 1.48.1
Desktop bw app: 1.24.6

Screenshot of the error

1 Like

Hmmm… everything is good on the windows version, but something not-so-obvious is that you actually need to use the non-windows store version for this to work. You can download it here: https://vault.bitwarden.com/download/?app=desktop&platform=windows

If you are already using that version, make sure the browser has this permission enabled under manage extensions: Screen Shot 2021-03-10 at 10.14.52 AM

I’m 99.9% sure I was using the non-windows store version but did a reinstall anyway to make sure.

The “Allow access to file URLs” permission was disabled for the extension. I enabled it.

Still, no change. Tried closing and re-opening the browser and the desktop app. I will try a reboot of the computer but really don’t imagine the extension permission change would require even a browser restart.

Appreciate the help and hope you have more suggestions! I will note that it would be great with a more accurate feedback message for the issue - clearly the permission is set in the desktop app. Rather seems the issue is with the connection to the app or something else. Unless of course it turns out that the desktop app doesn’t correctly communicate the setting’s state. :slight_smile:

Safari is getting an overhaul to use the new APIs in Big Sur, so the biometrics integration will be there when that update occurs.

The mentioned update should now be released with 1.49, but the Biometrics option is still missing and also on the Unlock with Biometrics help page Safari is still listed as an unsupported browser.
Has the integration been postponed again and if so, is there any ETA?
Or am I mistaking something with the new API in Big Sur and the browser-wide unification of the extension?

This was my mistake - I thought it was all bundled together - still in progress, sorry about that!

1 Like

I got everything working happily on Windows today, but my MacBook Pro is a no go:

  • macOS: Catalina 10.15.7 (19H524)
  • Bitwarden App: 1.25.0 (516) - installed from App Store, TouchID works great
  • Chrome: 90.0.4430.30 (Official Build) beta (x86_64)
  • Bitwarden Extension: 1.49.1

I gave the extension all the permissions and everything. Still no dice.

Same here, only difference is that I’m using Brave Version 1.21.77 Chromium: 89.0.4389.90 (Build ufficiale) (x86_64)

Gave extension full permissions, when I try to unlock with biometrics from Brave, there’s a flash of another Bitwarden icon opening in dock, closes instantly, and I get warning message that reminds to start Bitwarden desktop (which is open). I found in Console.app this message:
informazioni 09:21:20.857595+0100 safari in _willPerformHostCallback: block

1 Like

I tried creating tmp folder in ~/Library/Containers/com.bitwarden.desktop/Data as suggested here, but didn’t worked.

So I made a fresh install of Chrome, installed Bitwarden extension, configured unlock with biometrics, and worked in Chrome. Then I did another try with Brave extension (previously installed and configured): now it works in Brave too. Both extensions are 1.49.1, both from Chrome Web Store.

For the record: now tmp directory contains a special file created after Chrome install:
[email protected] 1 _____ ______ 0 20 Mar 09:34 app.bitwarden

Tried re-installing the extension and then the desktop app tonight. This time it worked - enabled Windows Hello in desktop app first and then in the integration - no issue now.

1 Like

I’m experiencing this issue too, though it does work in Chrome (beta) on MacOS.

But, it ONLY works in Chrome.
Safari = no
Other Chromium browser = no

I have this exact problem.

Will try the workaround.

I was able to enable biometrics in Big Sur for Edge Dev.

I created a new file with this path:

~/Library/Application Support/Microsoft Edge Dev/NativeMessagingHosts/com.8bit.bitwarden.json

and with this content:

{
  "name": "com.8bit.bitwarden",
  "description": "Bitwarden desktop <-> browser bridge",
  "path": "/Applications/Bitwarden.app/Contents/MacOS/Bitwarden",
  "type": "stdio",
  "allowed_origins": [
    "chrome-extension://nngceckbapebfimnlniiiahkandclblb/",
    "chrome-extension://jbkfoedolllekgbhcbcoahefnbanhhlh/",
    "chrome-extension://ccnckbpmaceehanjmeomladnmlffdjgn/"
  ]
}

Next time I tried to enable the “Unlock with biometrics” from Edge, a biometric popup appeared: I used my finger and the feature was finally enabled :sparkling_heart:

1 Like

Got some issues again on macOS + Brave and IMHO I can confirm that is the “tmp” directory the problem. Let’s sum up:

  • installed Bitwarden Desktop via App Store
  • installed Brave
  • installed Bitwarden Extension in Brave
  • enabled “Access to the file urls” in Brave Bitwarden Extension
  • launched Bitwarden Desktop, logged in my Bitwarden Account and enabled Biometrics and browser integration
  • while Bitwarden Desktop running, opened Brave, logged in my Bitwarden account in Bitwarden Extension and tried to enable biometrics unlock with no luck
  • opened Terminal, checked ~/Library/Containers/com.bitwarden.desktop/Data - it had no tmp directory in it
  • created ~/Library/Containers/com.bitwarden.desktop/Data/tmp
  • tried to enable biometrics in Bitwarden extension → now IT WORKS

:+1: - @Hinton I recall your PR to address the native messaging directory, but wasn’t sure if you’d run across this?

The tmp directory not existing should be fixed in the next release, and we’ve added support for creating the manifest for chrome beta/canary/dev and edge.

2 Likes

Now it’s working for me on Windows + Chrome Plugin

After you enable both checkboxes from the Desktop app

Unlock with Windows Hello
Enable browser integration

And then the Chrome Plugin

Hello,

I’m trying to enable the Windows Hello connexion to my Bitwarden Vault in the browser extensions :+1:

  • MS Edge Version 90.0.818.51 (Version officielle) (64 bits)
    • with Bitwarden Extension : v.1.49.0
  • Firefox 88.0.1 (64 bits)
    • with Bitwarden Extension : 1.49.1
  • Windows 20H2 last update on 2021/04/21
  • Bitwarden desktop app v.1.25.1 (not the store version)

I successfully activated the Windows Hello in the Desktop App :

But with the browse extensions, I’m stuck with this error :

On MS Edge, I checked the following checkbox :


(there is no same checkbox in Firefox…).

Is there a way to activate the Windows Hello in the browser extension while the same thing is working on the Desktop App… ?

Thanks for your help.