Linux version stops launching after system upgrade

Hello all, I use Bitwarden in Android and Linux (Manjaro, KDE edition) and from this morning, after upgrading Linux (testing channel) Bitwarden Appimage won’t launch anymore.

Same in 2 computers, same with the AppImage or even the AUR package rebuilded.
The message I get in the terminal is : Segmentation fault (core dumped). It appears in both machines.
Any idea ? Thanks

Have you tried reinstalling?

Yes, multiples times. There is already a comment in AUR, from another user. it says Since switching to bin it just segfaults and won't start. Seeing this in 1.5 also, and with AppImage.
So it seems to be an issue at the source. I bet some libraries have change with the last system upgrade…
See here :

So to be clear, this was an issue in 1.4.0 and still in 1.5.0? It worked fine until you updated Linux?

Exactly. Both versions were working until Linux (Manjaro-Testing) was upgraded this morning.

I’ve had this problem since the weekend using 1.4.0-1 and also with 1.5. It happened after my linux was upgraded to 4.17.12. Today it upgraded to 4.17.13 and the core dump still happens. Reinstalling doesn’t do anything.

How are you installing the app? AppImage?

The 1.4 was installed. The 1.5 was AppImage.

There is a bug report in the Arch linux which says that the update to glibc 2.28 causes some apps - including Bitwarden - to core dump. Downgrading to a previous 2.27 version fixes the issue.
On the Manjaro forum someone posted this as a working solution for downgrading and having Birwarden working: sudo pacman -U
Didn’t try it myself yet … may try tomorrow. For the moment I use the browser extension on my laptop.

Confirming that the fixes @pierrep56 do work for bitwarden on ArchLinux. 1.0.5 also seems to display properly. Reference

Also the snap version of Bitwarden works, as a workaround.
It is indeed a bug in Arch Linux, not in Bitwarden, and it affect various applications at the moment.

It isn’t just Arch. The problem also is happening for me, using Linux Mint.