Launch not working in BW for Windows, Never URI is not managed!

Hi, there is bug in BW for Windows, when you click on ‘Launch’:

Even though the 1st URI is set as ‘Never’, it is launched by this ‘Launch’ item:

Here is the webpage that shows up :
We should instead be on webpage. There is a bug.

You can very easily repeat this issue just by using these info into any Bitwarden Login entry. Can you please correct this by skipping ‘Never’ for launch.

This issue is even present in BW website:

When you click on ‘Launch’, the URI with ‘Never’ is launched as well !

Hi @Christop,

The Never-option relates to a setting for auto-fill (Match-detection = Never match). Launch is just like clicking any URL. It navigates to that page.

Kind regards

If you set it not auto-fill for this URI, it is not for having ‘Launch’ auto-filling it !! So it is clearly a Bug

If you want the webpage to be launched, you should re-arrange the order of your URIs so that the URI1 is, and URI2 is The “Launch” function always opens URI1, regardless of what setting you have selected for the match detection option.

As already explained by @djsmith85, specifying the URI match detection to be Never is strictly for the purpose of preventing Bitwarden from ever auto-filling the item’s login credentials on the specified website. This is a feature, not a bug.

What is your setting for the default URI match detection method (under Settings > Options)? And do you, or do you not want the login credentials to be auto-fillable when you go to and/or If the instructions in my first paragraph above don’t solve your problem, please explain further what behavior you are trying to accomplish, and we can help you configure the settings accordingly.

When you click on ‘Launch’ the NEVER URI is getting auto-filled, so it is doing what you do not want it to do. This is the definition of a bug.

This is the BW behavior I am telling is dump, a more intelligent Launch URI selection is necessary.

I want to have an icon for my BW entry. As Bitwarden is not providing an icon for , I had to add as URI ONE . This was done based on the recommendation of this same forum.

OK, you are using a work-around for customizing the vault icon. The forum topic that described that work-around also included a warning that by using this method, you have to give up the “Launch” functionality.

Second, to prevent auto-filling from occurring on, you need to change the URI match detection for URI2 ( to Host. This is because the way that matching is done when there are multiple URIs. You may wish to vote for the following feature request, if you want the “Never” option to have the effect that you were expecting:

I have voted for the feature # [URI Config - Add NOT Operator]

Thanks, I have added ‘Host’ to .

I wish BW offers the possibility to give explicitly the icon you want to be displayed, because a lot of URI have no icons. And honestly the workaround to use URI to manage Login entry icon is very dirty. Furthermore only providing the possibility to get an icon from the URI means we will never get an icon for Login entries about Android apps as their URI is androidapp://xxx , so once again no icon (BW is not picking the corresponding icon in the Play Store).