Installing Bitwarden on Ubuntu 22.04 fails: MSSQL missing stored procedures

After carefully following every step at Install and Deploy - Linux | Bitwarden Help Center I am unable to get Bitwarden peroperly working. I can navigate to the /admin. It asks me for my the admin email address which I provide. I get an activation email with a link which works fine and I am in the admin panel telling me everything is up2date. When I click on users I get redirected to /users showing a 404, when I press the back button I get an error: “Could not find stored procedure ‘dbo.User_Search’.” The same happends when I click organizations. Also a missing stored procedure.

When I try to create an account the backend response is:

{“message”:“An unhandled server error has occurred.”,“validationErrors”:null,“exceptionMessage”:null,“exceptionStackTrace”:null,“innerExceptionMessage”:null,“object”:“error”}

Going through the docker logs shows me a lot of mssql errors all stating that stored procedures could not be found.

I tried installing on a different machine resulting in the same problem. I tried reinstalling (removing everything) with a different database. Same problem, anyone got an idea what I might be doing wrong?

Quite a few other users talking about missing sprocs e.g.

I assume you have you confirmed your database has a dbo.User_Search ?

I managed to fix the problem by editing and change the version from
2023.2.0 to 2023.1.0

Hi Wim_Wisselink,

After editing the bash file did you do a reinstall or could we get away with a rebuild?

I’m assuming you edited the pull version just below the text that says “please don’t change pull version…” or something like that :smile: .

I’m curious to know how Bitwarden would suggest us to proceed. Will this approach Bork the app in some other way or can it have an effect on future updates?

Hey! Same issue here with the 2023.2.0. We had to shutdown and restart our servers for a maintenance last week and when coming back online, I had a ton of issues with Bitwarden. I spent 3 days trying to find what could have happened during the maintenance, and yesterday evening I tried to downgrade to the 2023.1.0, and everything was solved like magic!! Thanks for the tips!
In term of problems I encountered, I basically had the “unhandled server error has occurred” when I tried to login, create a new user, login in the admin panel, or try to send the verification email…
Looking at the logs, the main message was “ressource temporary unavailable”, either in the admin container or the identity one depending on the type of request I made.