Have to enter Master Password every website? This is crazy :(

I don’t get this at all. I have set up passwords in BW and gotten the Chrome extension. I sort of figured when I went to one of my websites it would fill in the password for me. Instead, I have to sign in to BW with my LENGTHY Master Password and then go check my email for the authentication code, back to the website and enter the code, look up the password in the vault and enter it --and do it AGAIN and AGAIN and AGAIN for every site I want to visit. This is a lot more hassle than I expected. :frowning:

You usually don’t need to copy and paste the password, simple click the Bitwarden Chrome browser extension, and it will then autofill the username and password. Alternatively, you can launch the site from within the Bitwarden Chrome extension.

You only need to enter your master password once to access the vault.

Unfortunately, you will need to sacrifice some convenience for security (e.g. using 2FA from your phone), but I think its worth it. You will get used to it quickly enough. All other password managers operate on similar principles, but I think Bitwarden is more snappier and responsive than others I have used or tried.

Furthermore, be aware that BW will ask for you to re-enter your master password every time you restart your browser and (depending on the settings you select) after a timeout. If you don’t close your browser though I find it easier than Chrome’s built in password manager

Thanks for responding, Col. You wrote, “simple click the Bitwarden Chrome browser extension, and it will then autofill the username and password.” That is what I thought it would do and why I am trying BitWarden, but I cannot seem to make it do that. The extension demands the Master password each time and then just sits there waiting for me to go through all the rigmarole before it will yield the password, which I then copy and paste.

What secret setting/option am I missing?

First thing you have to do is to set the timeout (the time it takes to lock and re-ask you for the master password).
Go to settings -> Security -> Lock Options and choose the timeout.

1 Like

Setting the timeout makes no difference. Every time you reopen your web browser (e.g. Chrome w/ Bitwarden extension installed) you have to reenter your master password. I agree with the original complaint here that this is a hassle and time waster. Lastpass doesn’t require you to reenter your master password every time you start a new session (i.e. reopen your browser). This should be SOP for password managers. Login once and from there on out, just automatically enter passwords for sites that need them.

@nbrenard Not true…While there is an option to “never” lock the vault, I don’t recommend it. There is an option to lock it with a pin code (which can be a whatever you want password). That way, even on browser restart, you only enter the shorter pin code and not the master password


I am trying Bitwarden for the first time on my iPhone. And Bitwarden has lost me at its inconvenient request for master password every time. Such a hassle to have to re-enter your master password every time you want the app to autofill your password on Safari or Google Chrome :expressionless:

Hi Sarah - I think most people setup BW to unlock with FaceID or a PIN so that they aren’t constantly entering their master password. Have you tried that?




I and others are experiencing an issue loosely relating to this (in our case, the master pass is being prompted and not saving, along with any vault items), which seems to have cropped up recently for users of the Chrome extension. Is this a known issue? See here for more detail: https://reddit.com/r/Bitwarden/comments/sqzhhs/issue_bitwarden_is_constantly_asking_for/

Hi @intp5 - have you tried any of the fixes mentioned here yet:

Having trouble with Bitwarden on Chrome? Read this - User-to-User Support - Bitwarden Community Forums

Thanks much, David–Yes, logging out & back in eventually did resolve the problem.

1 Like

I had this issue on previous BW version. I updated to latest and this issue is gone since.