FIDO2 support for macOS and Linux desktop client

@PossibleGhost - welcome!

Sorry for any confusion on the macOS front. We confirmed as you saw above that we’re blocked on macOS for the time being, but it is a priority for us.

1 Like

Any updates on Linux desktop client support? Looks like it’s blocked by the same issue as macOS?


Any updates for Linux desktop app?

1 Like

This is still an upstream issue and we are also waiting on a fix.

A new PR feat: add WebAuthn dialog support on macOS by EricRahm · Pull Request #31906 · electron/electron · GitHub was opened which has some very recent activity.

Hi @djsmith85 ,

I’m not sure to understand why I’m getting this screenshot:

  • I have a Macbook (2020) using Bitwarden for months, and it works perfectly
  • I’m trying to add Bitwarden to another Macbook M1 (2021) but I get this screenshot

I do understand Electron … but why there is a difference between the two?

Or maybe I, in the past, only enabled the security keys on Bitwarden after installing it on my Macbook (2020), making it working since then by unlocking with TouchID… thoughts?

Thank you,

Exact same error when trying to login in Desktop App. Manjaro Linux though.

Confirmed for myself as well, FIDO keys were working on Linux Bitwarden desktop installs until recently but then a Bitwarden update resulted in me getting the same error as @peace. My account is configured with a FIDO key being the only 2FA option added.

I cannot determine which version exactly but it worked on and before April 8th I believe.

Still an issue (mac and linux), any updates?

1 Like

@bwzrun @fbr @jeekkd @peace if you are still experiencing problems with the authentication process, please contact us through the support page: Get in Touch | Bitwarden so we can verify the status of your subscription.

@abanay my subscription is valid (I’m able to log in from other devices).

As mentioned previously in this thread it seems related to this

I got the issue 2 days ago, so if you didn’t make any chance since then I doubt something has changed. Maybe you could help the PR being merged if that’s the real original of the issue?

1 Like

Is WebAuthn now possible on the Bitwarden Desktop App? I have the most recent version installed on my MacOS and Linux machines, and it does not even come up as an option for me, even though I have FIDO keys installed in Bitwarden and they work in the browser. I can’t remember this ever being an option for the desktop app.

1 Like

Feature name

FIDO2/WebAuthn support for Linux desktop app

Feature function

Ability to login to the vault via a Linux desktop app when only 2FA that’s enabled is FIDO2/WebAuthn.


So Yubikey is confirmed to not work for Bitwarden on Linux? Damn.

@djsmith85 @Hinton @abanay could you please set it on the Bitwarden roadmap? I know it depends on Electron PR that is staled, but if you could have a look into it?

It’s a huge security issue for me and it looks urgent:

  • When using a Bitwarden browser extension and to secure it with the fingerprint we need to have the Bitwarden desktop installed and logged in
  • For maximum security I use security keys as 2FA, but since Bitwarden desktop requires security key to login whereas it does not support it… I have to enable another 2FA to bypass this issue and be able to log in. Making my whole Bitwarden account no longer secured by a physical key (which sucks).

If it’s not something that matters to you, could you set up a fallback: when the 2FA is security key in the desktop version, could you allow us to resolve the challenge into the default browser (so then the token or whatever is injected into the Electron app)?

Thank you,


Hi @djsmith85
Are there any plans from bitwarden to try and implement FIDO authentication in the Linux desktop app?
This remains an issue in the latest version 2022.9.1

1 Like

@djsmith85 @Hinton @abanay … 4 months since an admin answered this thread.

Is there no consideration for users using Macbook M1? I would like to understand if this will remain for too long or if I/we can count on the team?

Thank you,

1 Like

Is it planned to add support for Mac OS on Apple Silicon?

I cannot use biometrics authentication for Safari Extension. It’s major annoyance for me.


Hey @tymmej are you referring to Touch ID to unlock the safari browser extension? Or as 2FA from logged out state?

I can login in safari for macOS extension with 2FA. But in order to activate TouchID in extension I have to activate same option in app. I cannot activate it in app because I cannot login with 2FA in app.

In light of the recent announcement concerning Webauthn (, are there any plans to work on Fido2 WebAuthn (e.g. security keys) login for the MacOs or Linux desktop app? @bw-admin