Exception message: The operation was canceled

I was not able to add new logins from bitwarden app on Android and decided to reinstall it ;(

Now after reinstall, I cannot login…

Error popup I get (looks like timeout) is - “Exception message: The operation was canceled.”

Any help is appreciated ?

1 Like

Hello @Ran_Davidovitz , Welcome to Bitwarden community forums !

From your question , i think the timeout message refers to the “captcha session”. This has happened with me too earlier because i was using a browser which was blocking the captcha session due to some ad-blocking features implemented in it.
One-way i fixed this was by setting another browser as “default” for the time it authenticates your captcha and then you can revert back to your original browser later.
Hope it helps :+1:

Weird but without wifi it works .

1 Like

If that’s the case, then there is something interfering on your home network. You might try the following:

  • ensure that you are not operating over a VPN (VPN services are often the first IPs to be blacklisted, and Bitwarden is picky about security for obvious reasons)
  • reboot your router
  • disable IPv6 on the router
  • change your DNS settings on the device or route to a trustworthy provider, like Cloudflare, Cisco, or Google

I hope one of those works!

I will check but be please aware that this is the only app making me problems , and I guess for others ?

1 Like

Thanks for the wifi only hint. I had the same issue, and only with BW, on StarLink. I switched to another router and it worked.

1 Like

I had the same issue on Starlink. Any idea why Starlink specifically ?

I have the same issue, I am living in Germany and using a Telekom Speedport Hybrid Router, which combines LTE with my very bad DSL copperline. I hoped to solve this issue by deactivating my Wifi but unfortunately the problem still occurs on mobile data. I also switched to 3G mobile data because I read, that there might be issues with ipv6 but also no success.
The strange thing is, that everything works great in the browser on my phone, only the android app is having this issue.
Is there any update or suggestion I can try? Always accessing my bitwarden vault through android browser and not having the possibility to insert passwords from the android app is a bummer.
P.S. I even updated my ISP DSL account from LTE/DSL Hybrid to a 5G/DSL Hybrid contract with a different Router and additional 5G Modem, still no success :frowning:

I came across this issue randomly on my Samsung S10e, even though I am using it for many years. So I didn’t change the phone, nor the router and also not the app data or cache. I couldnt log in suddenly overnight. I really dont know what happened, but it must have been an App Update

Just for information, I got this error message and could not login into my self hosted Vaultwarden_RS instance using the iOS Bitwarden client because the “Limit IP Address Tracking” option was set in my iOS wifi options.

Hoping this helps some of those reading this thread.

Thank you for this answer.

I was getting "Exception message: The operation was canceled.” trying to access a self hosted Vaultwarden. Firefox (with an ad blocker) is my default browser. Changing the default browser to Chrome solved this.

Now I’ll look into exactly what’s being blocked by Firefox and try to whitelist it.