Caught in login-loop on Firefox (latest version )

First grumble: what is it with BW? Gotta login every time you sneeze or look away! Irritating.
Anyway… I go to a website (tripplite.eaton.com) and BW asks me to login to fill in form. Pop-up comes up, I enter my PW. the popup window goes away, then returns, asking me to enter PW again. It says I am currently logged into my account showing my email.
The webpage also has a BW overlay where I can click and it too does not go away.
The loop goes on and on. Maybe it’s this page?
Works on Chrome.
Firefox is up to date v. 115
Is there a feature where BW will stop asking me to login for a set period or session, ?
Luckily I have hotkeys for my long pw, or this would be a real deal breaker.
LastPass keep raising price, so I was about to drop them and switch to BW…but now I am not hopeful.

Go to the browser extension Settings (:gear:), set the “Vault timeout action” to “Unlock”, and set the “Vault timeout” period to an interval that suits your work habits. Optionally, enable Unlock with PIN so that you can use a shorter password for routine unlocking.

Frankly, I’m having trouble following your description. Start by letting us know what version of the browser extension you have installed, and what configurations you have set up in Settings > Auto-fill and Settings > Options > Ask to add/update existing login. In addition, posting some screenshots of what you’re seeing would help make sense of your descriptions.

Thanks for the quick reply.
I do not see the settings gear in my browser extension (v 2023.12.0). I went to download the desktop app and see it is only for Win 10 and 11. I do have machines with each of those OSes, but my favorite computer is still Win 7 x64…the one I am complaining about and currently responding on!.. so that may be my problem.
Guess I will now have to experiment on the Win 10 to see if BW behaves differently.
I was at least able to set time-out via the website prefs to 12 hrs. we’ll see if that works.

Bitwarden is not supported for Windows 7.

If you do not see the Settings icon in the navigation bar at the bottom of the viewport, then your browser extension installation is severley hobbled:

 

The settings configured in the Web Vault will not affect the behavior of the browser extension. Each client app has its own independent set of settings.

Thanks for your helpful explanations.
So now I know: BW extension won’t look like your example on Win 7. I tried. No toolbar at the bottom.
On Win 10 it does now, after updating Firefox and Chrome.
Now we know what we’re up against.

Try pasting the following in the address bar of your Chrome browser:

chrome-extension://nngceckbapebfimnlniiiahkandclblb/popup/index.html#/tabs/settings

Thanks for helpful tip,… I guess. I got error response
image

Anyway as noted in my previous comment, looks like my problems are due to sticking with Win 7. Extension works fine on Win 10.

And this led me to check out Roboform…which seems to work well on even older OS like Win 7.,…and so it may prove to be the most compatible for me who runs Win 7, 10, and 11. and still prefers SEVEN!

Was your browser in Incognito mode when you tried that? If so, try it again in a regular window.

I never use incognito mode. What’s the link about?

It was an alternative way to get to the Settings page of your browser extension.