Can't enable browser extension biometrics

Windows 10, Firefox 102.0.1 (w/ Bitwarden extension v 2022.6.0) Desktop Bitwarden version 2022.6.0.

I have gone through all the procedures listed above. Still says Browser Integration not enabled…even though it is enabled.

I am not using the MS Store version of either Firefox or Bitwarden.

Thank you for your assistance!

(Javascript, C++'s 2005 - 2022 x86 & x64 installed if any of that matters)

After some digging, I’ve got mine running again. I had to create a new key in the registry:

Next, I had to modify the default value to show:


After manually adding the key/value, everything works as normal.

This appears to be something that the developers have been struggling with for while. It is repeatedly acknowledged, but it’s an outstanding bug that nobody has fixed.


I had the same issue, except I didn’t set it to require fingerprint phrase.
After manually adding the mentioned registry key for Firefox it started working.

Maybe worth mentioning I installed both Bitwarden and Firefox using Chocolatey.
Otherwise new win11 setup.

So thank you for the fix :slight_smile:

Hi there,

I can’t use biometrics fingerprint unlock on Brave.
I use the browser extension 2022.6 and when i active the option, i have the prompt of Brave asking me the permission.
But when i accept it, my extension get lock and when i unlock it, the option is disabled and impossible to active it again, i got an error like the option is disabled on my desktop app and that is not the case.

I don’t understand how it’s possible.

For information, i am using a trustkey G320H.
My app is the 2022.6.1 version
The browser extension is the 2022.6


Thanks a lot, it’s working using the solution of @lbarnette
@bw-admin you have your fix here :slight_smile:

1 Like

In regedit the two keys exist :
with value : C:\Users\xxxxx\AppData\Roaming\Bitwarden\browsers\firefox.json
with value : C:\Users\xxxxx\AppData\Roaming\Bitwarden\browsers\chrome.json
but in C:\Users\xxxxx\AppData\Roaming\Bitwarden\browsers\
chrome.json is missing.


In regedit I removed the google key
since the json file was missing.

I restarted the computer, reinstalled bitwarden version 2022.5.1, cleared ‘windows hello’ and ‘browser integration’ options, and re-enabled them right away.

I then enabled biometric unlocking in both browsers (google and firefox) and everything works fine.

I restarted the bitwarden application which automatically installed version 2022.6.1 and everything is still fine.


Thank you! After digging online for days a variation of your solution got it to work for me.
For everyone struggling with enabling biometrics for Bitwarden in your browser, here’s how I did it (all credit to @mdeherder):

  1. Installed Bitwarden (current version 2022.6.1)
  2. Logged into Bitwarden
  3. Enabled Biometrics (Windows Hello)
  4. Enabled Browser integration
  5. Installed the Browser extension (in my case Firefox, but it also worked on Edge and Chrome)
  6. Logged into the browser extension
  7. Windows Key + R opens the “run” window
  8. enter “regedit” (without ") and hit enter
  9. Navigate to HKEY_CURRENT_USER\Software\Mozilla\NativeMessagingHosts\
  10. For me, the folder " com.8bit.bitwarden" was missing
  11. Right click on “NativeMessagingHosts” → New → Key"
  12. Name the folder “com.8bit.bitwarden” (without ")
  13. In this folder there is a “default” entry, double click
  14. In the value field, enter “C:\Users\YOURUSERNAME\AppData\Roaming\Bitwarden\browsers\firefox.json” (without ")
  15. Confirm, close the registry editor
  16. Now try enabling biometrics in your browser again, it should work (Click allow on the browser prompt)

For me it seems the problem is Bitwarden (the extension) or that the browser would not create the necessary registry entry.

For Chrome / Edge / whatever users:
This should be applicable for you as well. Just navigate to your browsers registry entry where you can also find the folder NativeMessagingHosts and create the same entry, just with a different value, eg “C:\Users\YOURUSERNAME\AppData\Roaming\Bitwarden\browsers\chrome.json” for Google Chrome

You can also use “C:\Users\YOURUSERNAME\AppData\Roaming\Bitwarden\browsers” to check if there’s a .json file for your preferred browser in that folder. For me, everything was there. If it’s missing, that’s a different issue…

Hope this helps.


In my case the chrome.json file isn’t present in the folder. I’ve done a clean installation of browser/desktop app and chrome extenstion but no chrome.json file presen instead there is a firefox.json file and I’ve never install firefox in my browser…

Anyone can help me?

See my answer above. I was in the same situation.

Is this problem still active with the developers? I still have the problem with both Chrome and Edge browsers. Windows 11 (all current updates), current Bitwarden desktop app (2022.6.2) and latest browser extensions. The registry hacks discussed here haven’t helped me.

Yes, thanks for your patience, the fix is still incoming.

For Windows users try this:

After enabling “Browser integration” in the desktop app, leave that same desktop app open and enable “unlock with biometrics” in all your browsers’ apps.

Worked for me on Windows 11! :grinning: :wink:

1 Like

many thanks mate, that did the trick
was about to give up on this ever working

This works for me in Windows 10/Firefox. Although there’s a typo in your keyname; the key should be com.8bit.bitwarden. Also in my case, the Mozilla registry directory was under HKEY_LOCAL_MACHINE.

Thanks @malmagel nice guide!

But it didn’t helped me at all.
Twicely checked Mozilla & Chrome registry entries "HKEY_CURRENT_USER\Software\Mozilla\NativeMessagingHosts" and configuration files in the "C:\Users\YOURUSERNAME\AppData\Roaming\Bitwarden\browsers"
Last versions updated for Bitwarden Desktop and Extensions,
But still receive a message when I press in extension settings - “Unlock with biometrics” :

Any idea or any help will be appreciated , cause I’m stuck with this issue for a long time.

1 Like

So You key located here, right ?

This location require administrative privileges for amends.
Perhaps it can helps, I’m curious , this is the last hope.

Put a key to "HKEY_LOCAL_MACHINE\Software\Mozilla\NativeMessagingHosts" doesn’t helped me at all.

Hi @romapop, welcome to the community!

Here is some additional troubleshooting to try:

For Windows, you may need to install the Microsoft Visual C++ Redistributable before Windows Hello can be turned on in Desktop Preferences: Latest supported Visual C++ Redistributable downloads | Microsoft Learn

To troubleshoot this, we recommend uninstalling the Bitwarden desktop application and remove any leftover data:

After that, follow these steps and let me know the results:

  1. Install the Bitwarden desktop application from this link: (it’s best to install the .exe from here, as there is limited support from the Windows Store application).

  2. In your Bitwarden Desktop app, navigate to Settings (on Windows, File → Settings).

  3. Scroll down to the Options section, and check the Allow browser integration box.

  4. In your Browser, navigate to the Extensions manager (e.g. chrome://extensions or edge://extensions), open Bitwarden, and toggle the Allow access to file URLs option.

  5. In your Browser Extension, open the Settings tab.

  6. Scroll down to the Security section and check the Unlock with biometrics box. You should be prompted by your Desktop app to input your biometric. Doing so will complete the initial setup procedure.

After completing that process, you should be able to unlock the browser extension with biometrics.

Additional Firefox troubleshooting

For the Firefox extension, you’ll want to make sure that the “Native Messaging” permission is enabled. It is an optional permission; however, it is required to function on Firefox:

Other users have also reported that disabling the “Run in Private Windows” function from the browser allowed it to connect properly on the next attempt.

@sj-bitwarden Thanks for trying to help!
But it didn’t helped at all. I’m still not able to use biometrics.
I was reinstalled everything, desktop and extensions for firefox and chrome with no success at all.
Currently in the Firefox I receive a message “Awaiting confirmation from desktop” with no any invites from desktop application.
In the Chrome I have still a message “Browser integration is not set up” .