Can't enable biometrics for Chrome or Edge browser extensions

I am a new Bitwarden user with a Premium Individual account. I have the Desktop application installed and configured on a Windows 10 PC and I also have both the Chrome and Edge browser extensions installed. The Desktop app is v1.24.6 and both browsers have the v1.48.1 extension. The PC has all current OS updates and I access it via a Microsoft account with Windows Hello (Face ID and PIN) configured and functioning correctly.

Everything about my Bitwarden configuration seems to work as expected with one important exception; I cannot get either the Chrome or the Edge browser configured for biometric unlock access. The desktop app is configured for biometric access and it works as expected. But even though the “Enable browser integration” desktop app setting is selected, the desktop app is running/unlocked, the browser extensions have the “Communicate with cooperating native applications” permission and all other browser extension features work as expected, I cannot successfully configure either extension to “Unlock with biometrics”. Selecting the setting in either browser extension results in a pop up window directing me to “Start the Bitwarden Desktop Application” alongside a running, unlocked Desktop application window displaying the account vault contents.

I have exhausted my troubleshooting repertoire and would sincerely appreciate any advice from community denizens.

7 Likes

When I had a similar issue, I learnt that you have to go to ‘manage extensions’ and allow the extension to “Allow Access to File URL”.

After this, I was able to complete the connection between the extension and the desktop app for Biometric Authentication.

Thanks for the tip but it doesn’t solve it for me. I am thinking about generating a bug report. I cannot see how a pop up directing me to “Start the Bitwarden Desktop Application”, presented alongside a running desktop application window in the unlocked state can be intended design behavior.

I just tried to reproduce this issue and here is what I did:

  • To start with I logged completely out of the extension: image

  • I started the Bitwarden desktop-app and logged in via Windows Hello, then minimized it to the system tray

  • I logged into the Bitwarden extension by typing the master password.

  • Went into the settings and activated Unlock with Biometrics

  • Had to confirm this with Windows Hello

  • Locked the Bitwarden extension: image

  • Clicked it, clicked Unlock with biometrics and used Windows Hello, got logged in: image

For this test I did not allow Allow access to file URLs.

So my recommendation would be to also start from scratch and follow the steps I mentioned above.

1 Like

Actually, I have already done the complete cycle you describe. I also removed/reinstalled the browser extension(s). All to no avail. The only other “start from scratch” task I can think of is uninstall/reinstall the desktop app. I have, of course, verified that all versions are up to date.

The thing that flabbergasts me is getting the “Start the Desktop Application” dialog alongside a running, unlocked incarnation of the desktop application actively displaying my current vault. The Windows Hello stuff works fine for unlocking the desktop app, and browser integration is selected.

Same issue here, just moving over to Bitwarden from Lastpass. Is there a bug report that I can upvote?

I have seen the same issue, reinstall/install over existing, that solved the issue on Windows 10

Been a content Bitwarden user for a few weeks.

Downloaded the new Bitwarden Desktop version 1.25.0 (516) from the Apple App Store yesterday and browser extensions ceased allowing biometric authentication. I have done the extension-remove-and-reinstall dance. With the Bitwarden Desktop application running, when I click “Unlock with Biometrics” in the “Settings” tab of the browser extension, a modal window appears that reads: “Start the Bitwarden Desktop application The Bitwarden Desktop application needs to be started before this function can be used.”

This affects the extension for Brave Version 1.21.76 Chromium: 89.0.4389.86 (Official Build) (x86_64)
& Chrome Version 89.0.4389.82 (Official Build) (x86_64).

[Update] Wanted to note that the machine is running Catalina, not Big Sur. For stability and security reasons, I don’t upgrade my OS until others have gone through the typical early-adopter pain.

1 Like

I believe you are absolutely correct. I’ve spent 3 hrs on my Macbook Pro 16 with Catalina trying to get it to work. A good thing I was able to go back to Ver 1.24.5 with time machine. The whole biometric thing on Edge is not working. Try not to upgrade till the Bit guys get it fixed. The desktop app was not enabling the safari extension either.

do the devs read these forums? browsing them, seems like the 1.25.0 release is riddled with issues across platforms.

1 Like

Thanks for the tip. I tried this and added “Allow access to file URL” which was “off”, restart Chrome but it didn’t help.

Same issue here in MacOS Catalina. Just updated the Bitwarden app from the Mac app store and now the Bitwarden extension in Brave keep saying " Start the Bitwarden Desktop application" when I try to use touch ID to login. It was working right before my update.

1 Like

Hi All,

We are aware of the issue that Biometrics is not working on Catalina+Chromium browsers. Our engineer is currently checking on the issue

5 Likes

Not just Catalina! Mojave too. Mac OS 10.14.6.

1 Like

+1 - Catalina/Chrome exact same problems. A very bad experience coming from LastPass, sorry to say.

Just an update that today (March 24, 2021) I upgraded to Bitwarden Version 1.25.1 (518) on MacOS Catalina and restarted the app and Chrome and still get the same error.

Please try the workaround provided by Oscar in Issue with unlock with Biometrics (OSX Catalina, Brave, Chrome) · Issue #1709 · bitwarden/browser · GitHub

> In the meantime manually creating the `tmp` directory inside `~/Library/Containers/com.bitwarden.desktop/Data` should resolve the issue.
4 Likes

Can confirm that simply adding the tmp directory worked for me, thanks @sugianto!

Yep. If you want the command line, it’s:

mkdir ~/Library/Containers/com.bitwarden.desktop/Data/tmp

Also - it worked for me only after restarting the Bitwarden app (there is no need to restart Chrome)

2 Likes

What if the directory already exists yet you still get the “Please start the Bitwarden Desktop App” error when trying to enable biometrics (Edge in Mac OS)?