Can't enable biometrics for browser extensions | Integration

After restarting my laptop since the installation of bitwarden 2022.6.0 I can no longer unlock by fingerprint on the browsers (Google or Firefox).
The desktop application opens correctly by fingerprint

Can you try the following?

  • In Bitwarden Desktop

    • ​Disable Login With Windows Hello
    • Disable Browser integration.
  • Restart your machine

  • In Bitwarden Desktop

    • Enable Browser Integration
    • Enable Windows Hello / Biometrics
  • In the Browser Extension:

    • Enable Biometrics

Hello,

Edge latest version on Windows 11 21H2. Followed every step, did not work. Please re-open this thread.

This scenario does not work for me.

Actually after re-installation of bitwarden desktop at level v2022.5.1 :
firefox with extension at level 2022.5.1 works
but not googlechrove with extension at level 2022.6.0

Thanks for confirmation, for those who the steps above do not provide resolution, the team is working towards a resolution.

Have same situation with Brave browser…tried everything…still getting Browser Integration not enabled

Windows 10, Firefox 102.0.1 (w/ Bitwarden extension v 2022.6.0) Desktop Bitwarden version 2022.6.0.

I have gone through all the procedures listed above. Still says Browser Integration not enabled…even though it is enabled.

I am not using the MS Store version of either Firefox or Bitwarden.

Thank you for your assistance!

(Javascript, C++'s 2005 - 2022 x86 & x64 installed if any of that matters)

After some digging, I’ve got mine running again. I had to create a new key in the registry:
“HKCU\SOFTWARE\Google\Chrome\NativeMessagingHosts\com.8bit.bitwarden”

Next, I had to modify the default value to show:

“C:\Users\USERNAME\AppData\Roaming\Bitwarden\browsers\chrome.json”

After manually adding the key/value, everything works as normal.

This appears to be something that the developers have been struggling with for while. It is repeatedly acknowledged, but it’s an outstanding bug that nobody has fixed.

4 Likes

I had the same issue, except I didn’t set it to require fingerprint phrase.
After manually adding the mentioned registry key for Firefox it started working.

Maybe worth mentioning I installed both Bitwarden and Firefox using Chocolatey.
Otherwise new win11 setup.

So thank you for the fix :slight_smile:

Hi there,

I can’t use biometrics fingerprint unlock on Brave.
I use the browser extension 2022.6 and when i active the option, i have the prompt of Brave asking me the permission.
But when i accept it, my extension get lock and when i unlock it, the option is disabled and impossible to active it again, i got an error like the option is disabled on my desktop app and that is not the case.

I don’t understand how it’s possible.

For information, i am using a trustkey G320H.
My app is the 2022.6.1 version
The browser extension is the 2022.6

Thanks

Thanks a lot, it’s working using the solution of @lbarnette
@dwbit you have your fix here :slight_smile:

1 Like

In regedit the two keys exist :
HKEY_CURRENT_USER\Software\Mozilla\NativeMessagingHosts\com.8bit.bitwarden
with value : C:\Users\xxxxx\AppData\Roaming\Bitwarden\browsers\firefox.json
and
HKEY_CURRENT_USER\Software\Google\Chrome\NativeMessagingHosts\com.8bit.bitwarden
with value : C:\Users\xxxxx\AppData\Roaming\Bitwarden\browsers\chrome.json
but in C:\Users\xxxxx\AppData\Roaming\Bitwarden\browsers\
chrome.json is missing.

2 Likes

In regedit I removed the google key
HKEY_CURRENT_USER\Software\Google\Chrome\NativeMessagingHosts\com.8bit.bitwarden
since the json file was missing.

I restarted the computer, reinstalled bitwarden version 2022.5.1, cleared ‘windows hello’ and ‘browser integration’ options, and re-enabled them right away.

I then enabled biometric unlocking in both browsers (google and firefox) and everything works fine.

I restarted the bitwarden application which automatically installed version 2022.6.1 and everything is still fine.

4 Likes

Thank you! After digging online for days a variation of your solution got it to work for me.
For everyone struggling with enabling biometrics for Bitwarden in your browser, here’s how I did it (all credit to @mdeherder):

  1. Installed Bitwarden (current version 2022.6.1)
  2. Logged into Bitwarden
  3. Enabled Biometrics (Windows Hello)
  4. Enabled Browser integration
  5. Installed the Browser extension (in my case Firefox, but it also worked on Edge and Chrome)
  6. Logged into the browser extension
  7. Windows Key + R opens the “run” window
  8. enter “regedit” (without ") and hit enter
  9. Navigate to HKEY_CURRENT_USER\Software\Mozilla\NativeMessagingHosts\
  10. For me, the folder " com.8bit.bitwarden" was missing
  11. Right click on “NativeMessagingHosts” → New → Key"
  12. Name the folder “com.8bit.bitwarden” (without ")
  13. In this folder there is a “default” entry, double click
  14. In the value field, enter “C:\Users\YOURUSERNAME\AppData\Roaming\Bitwarden\browsers\firefox.json” (without ")
  15. Confirm, close the registry editor
  16. Now try enabling biometrics in your browser again, it should work (Click allow on the browser prompt)

For me it seems the problem is Bitwarden (the extension) or that the browser would not create the necessary registry entry.

For Chrome / Edge / whatever users:
This should be applicable for you as well. Just navigate to your browsers registry entry where you can also find the folder NativeMessagingHosts and create the same entry, just with a different value, eg “C:\Users\YOURUSERNAME\AppData\Roaming\Bitwarden\browsers\chrome.json” for Google Chrome

You can also use “C:\Users\YOURUSERNAME\AppData\Roaming\Bitwarden\browsers” to check if there’s a .json file for your preferred browser in that folder. For me, everything was there. If it’s missing, that’s a different issue…

Hope this helps.

2 Likes

In my case the chrome.json file isn’t present in the folder. I’ve done a clean installation of browser/desktop app and chrome extenstion but no chrome.json file presen instead there is a firefox.json file and I’ve never install firefox in my browser…

Anyone can help me?

See my answer above. I was in the same situation.

Is this problem still active with the developers? I still have the problem with both Chrome and Edge browsers. Windows 11 (all current updates), current Bitwarden desktop app (2022.6.2) and latest browser extensions. The registry hacks discussed here haven’t helped me.

Yes, thanks for your patience, the fix is still incoming.

For Windows users try this:

After enabling “Browser integration” in the desktop app, leave that same desktop app open and enable “unlock with biometrics” in all your browsers’ apps.

Worked for me on Windows 11! :grinning: :wink:

1 Like

many thanks mate, that did the trick
was about to give up on this ever working