Can't enable Biometric Login in Firefox extension

Hello!

I’m running Firefox 99 on Windows 10 and purchased a USB Fingerprint Reader to use with Windows Hello. I was able to set it up with Windows, the Bitwarden Desktop App, and the Bitwarden extensions for Chrome and Edge without problems, but I can’t set it up with Firefox.

When I click the option to enable biometric unlock for the Firefox extension, the extension prompts me to confirm with the desktop app, but I don’t get any prompts for my fingerprint to be scanned like I did with Chrome or Edge.

Help please? I’d rather keep Firefox as my main web browser.

Hello @Infryndiira - welcome to the community forums! And I am sorry to hear that you are having difficulty getting biometrics to work with Firefox.

Have you followed this guide closely?

If you have already gone through this guide to setup biometrics on the Firefox extension for Bitwarden, try disabling the biometrics option, close Firefox, re-open it and re-enable.

If that doesn’t work, I would entirely uninstall the Bitwarden extension, restart Firefox, reinstall the extension, and then meticulously work through the guide I posted above.

I hope you get it working!

Hello, thank you for your quick reply.

I have followed the guide closely, and was able to properly set it up for both Google Chrome and Microsoft Edge. It’s only Mozilla Firefox that has been giving me this particular issue.

The problem is that I can’t enable biometrics because Bitwarden Desktop doesn’t ever give a confirmation request for a fingerprint scan. The extension has all required permissions, and Bitwarden Desktop works fine with both Chrome as well as Edge when it comes to biometric scanning.

I proceeded to reinstall the Firefox extension and worked through the guide again. The extension once again has the proper permissions and the Bitwarden Desktop programme is still set up correctly (again, it works fine with both Chrome and Edge) but I still don’t get a prompt for a fingerprint scan to even pair Firefox with Desktop despite it waiting for one.

Attached you will find a screenshot.

Sorry to hear that didn’t resolve your issue, @Infryndiira.

I wish I had a biometrics device on a Windows PC that I could use to try and replicate this. But perhaps someone else out there has experienced something similar and will chime in?

@Infryndiira - one other thing to try that came to mind. In the Bitwarden desktop app, have you tried disabling and then re-enabling the option to Enable Browser Integration and then disabling and re-enabling the “Unlock with Biometrics” option in the extension? I have heard the odd person mention that playing with the order in which they enabled/disabled those two options made a difference.

Thanks for your assistance.

I tried what you suggested, but still get the same results. Absolutely no luck with Firefox.

Hello,
I have tried this on my computer, running Windows 10 Pro x64-bit
Version 21H2 (OS Build 19044.1620)
This appears to work with Windows Hello biometrics within Firefox and the Desktop app integration in my testing.

Bitwarden Desktop Application

Version 1.32.1
Shell 16.0.7
Renderer 96.0.4664.110
Node 16.9.1
Architecture x64

Firefox Browser

Version 99.0.1 (64-bit)

Bitwarden FF Browser Extension

Version: 1.57.0

I even tried to load the browser extension from the Firefox sidebar, which promptly unlocked with Windows Hello fingerprint biometrics.
Would you perhaps be able to set up Windows Hello with a PIN option even temporarily (this is different from the PIN option in the Bitwarden browser extension), as this may help to test if this is a Firefox and Windows Hello issue, or specifically with the add-in fingerprint reader.

You may also try to enable the extension in a Private Window view, or even try to load it up in a new Firefox profile. I would also attempt to reinstall the Firefox browser if you haven’t already.

Thank you for the recply cksapp.

I performed both a reset on Firefox as well as a full reinstall with a reset, and also tried setting up Bitwarden through a private window as you suggested. Unfortunately, I haven’t had any luck. My Firefox and Bitwarden versions are the exact same as the ones you posted, which makes it that much more perplexing.

Windows Hello is set up with both a PIN and a Fingerprint; the problem is that I’m never prompted by Windows Hello for a confirmation, and this happens only for the Bitwarden Firefox extension. Following the exact same steps on Chrome or Edge gave me the confirmation window so I could enable biometrics, but it doesn’t happen with the Firefox extension at all. This gives me the impression that it might be unrelated to Windows Hello, but I could be wrong?

I notice I use a slightly earlier Windows 10 build than you do though. I’ll update that and return with my results.

Updating Windows to the latest build didn’t resolve my issue either.

I’m having the same issue.

Clean Windows 11 reinstall today, doesn’t work in Firefox (99.0.1). Says "Browser integration is not enabled". But it is since I was able to set it up in Chrome and Brave without any issue.

Only thing other than Windows Updates that have been installed is the Microsoft Visual C++ Redistributable, Chrome, Brave, Firefox, and the latest Bitwarden Desktop App downloaded from the website.

Try disabling browser integration in the Bitwarden Desktop App and then re-enabling it again. That has worked for some folks. Let us know if it solves your issue. Cheers!

Did not work. Also tried reinstalling the Desktop App without success.

This is clearly a bug since it’s not working on a clean reinstall.

I would check your browser extension settings for Firefox before deciding it is a bug. Each Bitwarden client has independent settings, like whether or not to use biometrics.

It could also be that Firefox on Windows doesn’t support it - I found that out for WebAuthn, which Firefox on Mac mysteriously is the only major browser that doesn’t integrate it yet.

I’ve checked. The extension has all permissions enabled, including “Exchange messages with programs other than Firefox”.

Firefox on my other (Windows 10) PC is working just fine with biometric unlock enabled.

I don’t know then - there haven’t been many reports of Firefox not working. Windows is so finicky with biometrics devices, so hard to know if it is a Firefox-Windows issue or a Bitwarden-Firefox issue. Hopefully others will chime in here if they are having problems, also.

Either way it’s clearly a bug that Bitwarden needs to fix if biometrics don’t work on a clean Windows 11 install.

If you can confirm that everything is supported under Firefox, I’ll believe you. Otherwise, I am always skeptical of Firefox not supporting current standards, like WebAuthn on Mac (wait - did I mention that already??). :smiley:

https://www.google.com/search?client=firefox-b-d&q=windows+biometrics+not+working+in+firefox

I’m running the same version of Firefox (99.0.1) on my Windows 10 system and biometric unlock works fine. I’ve had it enabled on that system since biometric unlock support was officially added to Firefox.

So you are saying Bitwarden and biometrics on Firefox works on Windows 10? Sounds like Windows 11 is the issue, my friend.

Again, a bug that Bitwarden will need to resolve.

Windows 11 is a supported OS and biometric unlock isn’t working on a clean install (but works just fine in Chrome and Brave).