Can't enable 2FA with authenticator apps in Community Forums

I am trying to enable 2FA in Community Forums but I am getting below error.

“Invalid authentication code. Each code can only be used once.”

I tried several times but all failed. I was able to add my Yubikey but not a single mobile authenticator app, nor Bitwarden itself worked. Forum security settings are rejecting my OTP codes with above error and cannot save it afterwards.

Hey @Naxterra can you check your system clock to ensure it is accurate? You may need to wait 30 seconds, grab the new token and submit.

Hello

I am trying both from my mobile and computer. All are failing

Are both devices on the same network ? Try another one (WiFi vs. mobile).
And also check the time zone.

By the way: You did not mention if you verified the time on your devices.
Try https://time.is and select your location or add your country’s name or the name of the time zone behind the URL.
Examples: https://time.is/China or https://time.is/CEST

Hello

Both devices have time according to https://time.is

I tried with 5G and wifi on my mobile. I tried with Raivo, Authy and BW but all of them are failing for this forum. On other sites they are working.

Strange. I just opened up an incognito tab on Chrome and could log into the forum without an issue using ID, password and of course a TOTP.

I think I found the problem. I was trying to use same QR code for multiple apps like I did all other apps but when I used QR code for single device, it worked. Not sure why

There is a simple solution to that: Ignore the QR-code and instead add the code manually to multiple apps.

That didn’t work too. All of my authenticators were generating same OTP but website didn’t accept the code

I believe I ran into this same issue a few months back when I did this for my account here.
Oddly enough same concern, multiple TOTP apps sharing the same token and produce the same code as expected but this doesn’t work when attempting to generate the code with multiple TOTP services.

You can generate multiple TOTP codes though for each authenticator as you mentioned which seems to work, simply nickname each so you know which are which.

Thanks everyone! We’ve re-synced the forum server, which should resolve any TOTP authentification issues.