BW providing incorrect 2FA codes on Chromebook Linux Brave browser

When using Bitwarden on the web in the Brave browser on a Chrombook via Linux the 2FA codes are incorrect. The ARE correct when:

  • Using BW in Chrome on the same Chromebook
  • Using BW Android App
  • Using Windows Bitwarden
  • Using Bitwarden in Brave browser on Windows

So, I don’t think it’s the Chromebook nor Brave. It ONLY gives incorrect codes when using Brave on a Chromebook (via Linux).

Just a guess: Does the Brave browser on the Chromebook use a VPN?

It does, it is the Google One VPN built into Chromebooks. However, I have tried it with it off, with the same results. And, it works in Chrome browser (with the VPN on).

I do not mean a VPN that is installed on the device, but instead one that is integrated into the Brave browser itself; like what you can use with Opera.

Thanks for your help, btw.

No, there isn’t a VPN installed. I also tried it in Brave beta. I’m beginning to suspect it has something to do with the fact that it is running in linux on my chromebook, but I don’t know.

I’m not too familiar with Brave but these issues are almost always due to a time or timezone discrepancy. Is there any setting in Brave that might relate to this?

But then it also would not be ok with the Chrome browser, but according to OP this works.

No, I’m asking if there are any settings related to time or timezone within Brave.

thank you all for your help.

No, Brave doesn’t have a separate time/date setting. It pulls it from ChromeOS.
Below is screenshot of both Brave (left) and Chrome (right) side-by-side showing Bitwarden and the different codes. I do see that the countdown timer of the 2FA being unsychronized.

Try something like in both browsers. In theory they should show the same.
The for me surprising thing is that the TOTPs are not even showing the same remaining seconds.