Bw CLI does throw TypeError: Cannot read properties of null (reading 'toLowerCase')


  • I am on macOS (x86) and did install the CLI with homebrew.
  • Everything ran flawlessly for some years but now I always get an exception when I try to search for something:
bw list items --search google
                c.login.uris.some((loginUri) => loginUri.uri.toLowerCase().indexOf(query) > -1)) {

TypeError: Cannot read properties of null (reading 'toLowerCase')
    at /usr/local/Cellar/bitwarden-cli/2022.8.0/libexec/lib/node_modules/@bitwarden/cli/build/bw.js:23363:62
    at Array.some (<anonymous>)
    at /usr/local/Cellar/bitwarden-cli/2022.8.0/libexec/lib/node_modules/@bitwarden/cli/build/bw.js:23363:30
    at Array.filter (<anonymous>)
    at SearchService.searchCiphersBasic (/usr/local/Cellar/bitwarden-cli/2022.8.0/libexec/lib/node_modules/@bitwarden/cli/build/bw.js:23348:24)
    at ListCommand.<anonymous> (/usr/local/Cellar/bitwarden-cli/2022.8.0/libexec/lib/node_modules/@bitwarden/cli/build/bw.js:34965:46)
    at (<anonymous>)
    at fulfilled (/usr/local/Cellar/bitwarden-cli/2022.8.0/libexec/lib/node_modules/@bitwarden/cli/build/bw.js:34860:58)

Node.js v18.7.0
  • The same error occurrs when I run something like bw get password google.
  • As a workaround I have to dump all items and look for the ID, given that one I can now run bw get password 1a92938e-26dc-487d-9ba3-13f2cb7aa4de but this is rather tedious to remember.
  • bw sync does work. The App and the browser extensions in Safari and Chrome do work as well.

Full disclosure:

  • I pay for a Premium membership to support Bitwarden but am using a private vault-warden server should that matter (I do not think so as to my knowledge searching and decrypting happens on the client).

Am I the only one which runs into this error?

Best Regards

1 Like

Hi @mfriedenhagen,

I just wanted to let you know, that you are not the only one, that has experienced this issue.

The issue was reported with An error based on 2022.8.0 version - Cannot read properties of null (reading 'toLowerCase') · Issue #3267 · bitwarden/clients · GitHub and a Pull Request has been created to fix this issue.

Until the fix is released, here are some instructions for a work-around.

Kind regards,

Thanks @djsmith85, I found the offending entry by executing

bw list items | jq . | less 

and looking for "uri": null in the output. After that I removed the empty URI in the entry :slight_smile: