Browser Extension: When setting Unlock with PIN, text field not hidden by default

Hello!

I believe, “Unlock with PIN” should be a hidden field. What do you think? I noticed this shows my PIN in clear-text by default when enabling. Considering this can be used to unlock the vault, same with master password, PIN should be hidden when enabling by default.

How about some more details like OS, fully updated yes/no, browser name and version, etc.

W10, Chrome and MSFT Edge (all fully updated): PIN is hidden:

Re-reading the OP’s post, I think he means when setting the PIN for the first time.

Maybe that input field should have a “Toggle Visibility” icon like in the Verify PIN dialog?

1 Like

@Peter_H : As mentioned by @dh024 and if you reread my post the PIN is not hidden on first setting a PIN. I agree with you after the PIN is initially set it is hidden (notice ‘Verify’ in your image). If it is acceptable the PIN should not be hidden when it is first set, then should passwords when first set also not be hidden? On almost any site all passwords when first set are hidden by default. Same should be for the PIN in my opinion.

See images below. I guarantee you can easily reproduce on any OS / browser with the current version of BitWarden @Version 1.27.1 (531).

Steps to reproduce:

In any browser → Select: Settings

1. Ensure PIN has not been enabled/checked

2. Enable PIN by ensuring it is checked
image

3. Notice when first setting PIN it is shown in clear text w/o option to hide/show

Oh, sorry. You are right, I misunderstood your request. Thank you for clarification.

1 Like