Bitwarden-mssql restarting - file archive invalid

Hello –

I’ve been searching for this issue for a few days. My instance of bitwarden-mssql keeps restarting with the this error and it’s the only thing in the log (but every second or so):

$ docker logs --tail 50 --follow --timestamps bitwarden-mssql
2024-03-18T01:19:12.132932075Z /opt/mssql/bin/sqlservr: The file archive [/opt/mssql/lib/sqlservr.sfp] is invalid.  Please resolve and try again.

I’ve tried enabling IPv6 and that didn’t work. I’ve completely removed Bitwarden and reinstalled, but the issue came back a couple days later. I’ve tried rebooting with each kernel available to the system. I can’t ‘docker exec’ into the container nor can I run ‘bitwarden.sh updatedb’ because the container won’t start.

$ cat /etc/redhat-release
Red Hat Enterprise Linux release 8.9 (Ootpa)
$ docker --version
Docker version 25.0.4, build 1a576c5
$ docker compose version
Docker Compose version v2.24.7

Note the specific flavor of RHEL is Oracle Linux with UEK removed.

Any help would be greatly appreciated.

**Edit to add:

  • Running in VirtualBox
  • 4 vCPU
  • 12 GB RAM (added as a potential solution. Will probably reduce back to the original 8GB)
  • Disk space shouldn’t be an issue.