Bitwarden does not show as Safari extension (MacOS)

I’ve updated to that version too, with Safari 15.1 and the extension is missing even after clearing cache.

Seems that there is a fix on the way: Ensure safari extension is included in mas and not only darwin by Hinton · Pull Request #1128 · bitwarden/desktop · GitHub

Until then, I guess I’m back on Firefox…

1 Like

Same here ! Hope it will be fixed soon.

Was requested to close Safari (15.1) on Monterey to update Bitwarden (to 1.29.0 I assume) and now there is no Bitwarden Extension listed in Safari. Rebooted and reinstalled Bitwarden Desktop from the App Store, but nothing.

Any fix ?

Thanks

Same here on Monterey. You can use the previous version of Bitwarden from Time Machine, or another backup, if you have it. They are aware of this and said there will be a fix.

Fix has been submitted to the app store - once approved it will be available via a standard update.

6 Likes

Thank you for the update!! :+1:

That fix had better work or else I will move to 1Password.

I also have this issue om my Macbook/Safari

I installed Bitwarden from App Store but still the Safari Extension is not available to be selected.

Same. BS 11.6, Safari 15.1, Bitwarden 1.29.0 from App Store, extension missing from Safari. Rebuilding Launch services with Onyx didn’t fix.

For me it was the same as in an earlier discussion. In order to have the extension show up again, I needed to use AppCleaner.

I installed Bitwarden 1.29.1 but the extension is still missing in Safari.

It was told that 1.29.1 should resolve the issue - but it does not.

1 Like

Have installed update and all working again.

Thanks.

I’ve installed the update and I am still missing the Safari extension.

Welcome, @chk18!

You’ll need to go into Safari’s preferences and re-enable it under Extentions.

If it’s not there, you may need to rebuild launch services using the following command - or use the maintenance function in Onyx for macOS.

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

5 Likes

The extension wasn’t listed when I went to enable it, but I tried your second suggestion and that did the trick. Thanks for the help!

1 Like

Enabling Safari extortion worked for me.

After upgrading MacOS to Monterey - the Safari extension is back and working.

If I use Onyx, can I use just that one option? That is, Rebuilding: Launch Services database,
or should I be selecting other options as well?

The reason for my question is that I did select only that one option and Bitwarden extension is still missing.

MacOS 11.6.1
Safari 15.1

I believe so, but I am not an expert on Onyx, unfortunately.

Is the extension not showing in Safari > Preferences > Extensions ?

1 Like