Android app closes when selecting "generate password"

I just experienced the following reproducible issue with the mobile app on Android:

  1. Open some login page of a website where your credentials are not stored in bitwarden
  2. Click on the password field and select the pop-up to fill with bitwarden
  3. The app opens, unlock the vault
  4. No matching entry is found, click on the provided button to create a new entry
  5. Click on the “generate passwort” button next to the password field
  6. The app closes immediately (and the vault is locked)

I observed this behavior both with Firefox and Chrome on Android.

When opening the app directly and taping the plus button to create a new entry everything works as expected and the password generator opens without crashing.

1 Like

Hi @laikoni , thanks for joining community and reaching out! That’s one I haven’t heard before. Have you tried removing and reinstalling the app?

If that doesn’t work, you can reach out to the official support team here: or file a bug report on Github for the team to investigate:

This has previously been reported with Crash on click generate a password · Issue #2149 · bitwarden/mobile · GitHub and has already received a fix. This will be solved witht the next update (2022.11)


Good catch @djsmith85 ! Thanks for the support.

1 Like

Hey all, you can also access to the beta to get the fix early.