Add unshare option (1 click move organization vault item to individual vault)

I don’t understand this: I’ve just tried as you suggested because I ran into the same problem. But there is no clone option for organizational vault items

Move is only possible from personal vault to organization
Clone is only possible for personal vault items

So how exactly do you do it?

What am I doing wrong?:
20220109-101012-007
20220109-101140-008

Sorry guys I figured it out by myself: You will have to navigate to the organization first (which will only show your organizational items) and then you will get the clone option:

A little unintuitive that the clone option is not displayed in your whole vault overview… (I don’t know why, it does not make sense to me).

2 Likes

I agree that this should be possible. You can move an item from a vault to a collection within an org but not in reverse. This should be possible. And at the very least, it should warn you before moving the item to let the user know that this is an irreversible decision.

For now, I created a new collection in my organization called Personal that only I have access to. When the sharing of the creds is done, I move the item from the shared collection to a Personal collection to stop sharing but still retain access myself.

To move the item from the Personal collection back to my vault, I’ve copied and pasted the values manually which is a pain but do-able.

For the CLI inclined, you can use the bitwarden-cli with some jq magic. After logging in using bw login and setting the session token to unlock the vault, I followed this guide to get an item and recreate it.

Here is how I copied my southwest credentials from a collection back to my vault.

Find the cred in your app and ensure it has a unique name. Mine is called “southwest” but it’s possible you could have multiple items. Verify the correct value is returned.

bw list items | jq '[ .[] | select(.name | ascii_downcase | contains("southwest")) ] | .[0]' | less

Then clear the collectionIds and organizationId keys and pipe to bw encode | bw create item. I also piped to jq .organizationId to ensure it returns null.

bw list items | jq '[ .[] | select(.name | ascii_downcase | contains("southwest")) ] | .[0]' | jq '.collectionIds = []' | jq '.organizationId = null' | b
w encode | bw create item | jq .organizationId

Resync your vault using bw sync locally and using the app. Your new cred should appear in both your personal vault and your collection. You should now be able to delete it from your collection.

I can’t believe this is not an option.

I noticed I have been accidentally creating several entries directly in my Organization. My only option is to clone it, then remove it from the Organization.

What I do not get is there’s an option to do this within the Clone, but not in the original entry. I get this may be a security thing, but then simply add it to permissions of owner, etc.

This is really frustrating!

1 Like

I suppose it is not a huge deal to go to one’s web vault, go to organizations, clone an item and save it to one’s personal account and then delete the original item. But then again, it would be a lot easier to just remove it from the organization, the same way it was moved to the organization and even easier if it could be done from the app vault in addition to the web vault.